PA2EON & HAMnet

Informatie pagina's betreffende HAMnet

User Tools

Site Tools


gl.inet

GL.Inet Mini Wifi adapter voor Hamnet met OpenWRT.

Met deze mini AP die ingericht is met OpenVPN op basis van OpenWRT is het mogelijk om bijvoorbeeld
een Ipad te laten communiceren met het Hamnet of het Internet via 1 device.
Aanloggen met de VPN client software is dan niet meer nodig en is een transparante Hamnet verbinding mogelijk.
Let wel dat deze oplossing niet echt een router gerichte oplossing is en dus puur voor een prive AP bedoeld is !
Op deze pagina is te lezen hoe e.e.a. wordt ingericht.

 = = De hier beschreven informatie is nog in beta fase = = 

We beginnen met de hardware als volgt aan te sluiten:

 LAN Uplink: De LAN laten we met het eigen (inhuis) netwerk communiceren via DHCP
 WLAN Setup: De WLAN (antenne) is voor de draadloze toegang van de eigen apparatuur
 WAN Link  : Via OpenVPN verbonden met het internet - (op welke manier volgt ! )

De hardware die we gaan gebruiken is van het type 6416A met 64 Mb Ram en 16 Mb flash geheugen
De GL.Intet AP wordt met OpenWRT geleverd, echter ook met een eigen interface, die hebben we niet nodig dus we gaan eerst zorgen dat er een schone OpenWRT actief wordt op de AP.

   Ga naar: 'wiki.openwrt.org' en dan naar het hoofdstuk GL.iNet

Daarna gaan we de juiste OpenWRT software downloaden.

   Ga naar: 'downloads.openwrt.org' en ga naar de folder van de ar71xx/generic/ 
   Kies vervolgens het bestand: openwrt-xx..gl-inet-6416A-v1-squashfs-factory.bin 

Plaats de file op je computer.
Koppel de GL.Inet router (LAN poort) aan je PC d.m.v. de netwerk kabel.
Check het IP nummer wat de PC ontvangt van de GL.Inet (zeer waarschijnlijk 192.168.8.1)
Klik de standaard vragen zo eenvoudig mogelijk door, alles wordt toch overschreven door deupdate
Ga naar het Advanced menu en kies de 'Backup/Flash Firmware'

 Maak eerst een backup firmware bestand alvorens je verder gaat !

Start nu de firmware update - vink de optie 'Keep Settings' uit !
Wacht geduldig af tot je weer kan inloggen, en de melding ziet staan dat er geen wachtwoord ingesteld is.
Hierna komen de stappen zoals het instellen van de LAN en WAN verbinding.

Na de reboot staat de GL.Inet op het ip adres 192.168.1.1 (via het LAN verkregen IP adres)

De twee ethernet poorten en Wifi richten we als volgt in (de basis configuratie):

WAN - Ip nummer van DHCP van het internet (via router of eigen netwerk) LAN - Moet via ingebouwde DHCP server zelf nummers uitdelen kies een ander netwerk dan die van het WAN

    (bijv. 192.168.8.x)

Wifi - Moet via ingebouwde DHCP server zelf nummers uitdelen.

Voor Hamnet moet er een configuratie plaatsvinden via OpenVPN van de LAN/Wifi poort naar het WAN
In de loop van de opzet van dit schrijven zal dat duidelijk worden.

Tip:  Verken de OpenWRT software door op alle menu's te lezen wat er staat, pas nog niks aan !

Verbind nu de kabels (LAN en WAN) en ga nu naar de menu optie:

Network - Interfaces

Begin met de LAN verbinding in te richten:

General Setup - Static address - 192.168.8.1 (pas deze aan en sla op - daarna browser refresh)
DHCP Server (behoeft geen aanpassing)
Save&Apply

Je moet nu opnieuw aanmelden - check daarna of je nu via de ingestelde waarden naar het internet kan.

We gaan nu de basis programma onderdelen voor OpenVPN installeren en activeren en wel zo dat de OpenVPN server als OpenWRT router gaat functioneren.

Om te beginnen moeten de installatie software module 'opkg' installeren ga hiervoor naar:

  System - Software - Available Software - O - 'Install' opkg

Om nu een totale lijst van de te installeren programma's te krijgen druk op de button 'update available packages'
Daarna gaan we weer naar:

  System - Software - Available Software - O -
  Zoek in de totale lijst naar openvpn-openssl 
 + + +  PAS OP - onderstaande is nog niet klaar + + + 

Hierna moeten we configuraties gaan aanpassen in de router zelf, dit doen we door contact te maken met de GL.Inet via SSH terminal (putty) - log aan en login als 'root'.

We plaatsen nu de *.crt en *.key bestanden in de /etc/openvpn/ directorie. Ja kan dit het eenvoudigste doen door plakken en knippen (van de ascii inhoud) van de PC naar Router via de ssh terminal.

   ca.crt
   cert.crt
   private.key
   tls.key

Aanvullende informatie van de site:
https://www.loganmarchione.com/2015/02/openwrt-with-openvpn-client-on-tp-link-tl-mr3020-3/#Setup_NTP

Naast de *.key en *.crt bestanden hebben we de file [call].ovpn nodig.
Plaats deze file met de volgende inhoud in de /etc/openvpn/ directory.

   client
   dev             tun
   proto           udp
   remote          gw-44-137-ext.ampr.org
   nobind
   persist-key
   persist-tun
   ca              ca.crt
   remote-cert-tls server
   reneg-sec       0
   comp-lzo
   cert            cert.crt
   key             private.key
   tls-auth        tls.key 1

Vervolgens moeten een paar voorbereidingen gebeuren in de netwerk en firewall instellingen;
Eerst maken we de tunnel interface voor de VPN verbinding:

     /etc/config/network
     !
     config interface 'HamnetVPN'
        option proto 'none'
        option ifname 'tun0'
     

/etc/init.d/network restart

Daarna moeten we de link leggen tussen de lan/wifi poort en het hamnet op wlan.

Pas in de file '/etc/config/firewall' de volgende regels aan:

  config zone
    option name 'VPN_FW'
    option input 'REJECT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option mtu_fix '1'
    option network 'HamnetVPN'
    !
  config forwarding                               
    option dest 'VPN_FW'                    
    option src 'lan' 

Dan als laatste de opdrachten:

 /etc/init.d/network restart
 /etc/init.d/firewall restart    

En om de VPN tunnel te testen in deze (tussen situatie) kun je het volgende commando geven;

 openvpn --cd /etc/openvpn --config /etc/openvpn/pa2eon.ovpn --remote [call_externe_server].ampr.org 

Om nu de Hamnet VPN tunnel bij herstarten van de router actief te maen plaats bovenstande regel in de de file /etc/rc.local maar dan zonder de '–remote optie' en wel als volgt;

   # Put your custom commands here that should be executed once
   # the system init finished. By default this file does nothing.
   openvpn --cd /etc/openvpn --config /etc/openvpn/pa2eon.ovpn 
   exit 0

Maak daarna een reboot van de GL.Inet en controleer of je het Hamnet weer op kunt komen.

+ + Deze 'handmatige fase' moet eerst goed werken alvorens naar de Wifi oplossing te gaan + +
    
gl.inet.txt · Last modified: 2015/10/19 21:49 (external edit)